WRJC

Clicking in front end

0 Members and 1 Guest are viewing this topic.

Offline CaribouActual

  • ***
  • 201
  • Do it right or do it twice
Re: Clicking in front end
« Reply #15 on: March 10, 2016, 09:37:04 AM »
The bushing is still there haha.

And the clicking isn't gone. I lied. It's just not as prevalent. Front DS is removed, and the sound mostly comes when there's torque being applied. Might it be gears in the front diff? Or the ujoints somehow (even though they're all good)?


Sent from my iPhone using Tapatalk

Offline CaribouActual

  • ***
  • 201
  • Do it right or do it twice
Re: Clicking in front end
« Reply #16 on: March 10, 2016, 09:45:36 AM »
Engine related, maybe?


Sent from my iPhone using Tapatalk

Offline Oscar

  • *
  • 14802
Re: Clicking in front end
« Reply #17 on: March 10, 2016, 09:56:12 AM »
check all your fluids in the tcase and trans
Honorary Lifetime Member 2016-Present
WRJC President 2014-2016
WRJC Charter Council Team 2013-2014
SFWDA Director of Public Relations 2015-2016

Offline CaribouActual

  • ***
  • 201
  • Do it right or do it twice
Re: Clicking in front end
« Reply #18 on: March 10, 2016, 10:11:48 AM »

check all your fluids in the tcase and trans

I topped off trans in January. Tick appeared about a month or so ago, went away after that day, just came back yesterday or the day before. Sounds like a card in a spoke and happens when there's acceleration in the lower gears. Sometimes in high RPMs in third gear.


Sent from my iPhone using Tapatalk

Offline TJ Todd

  • *
  • 2605
Re: Clicking in front end
« Reply #19 on: March 10, 2016, 10:14:12 AM »
Engine related, maybe?


Sent from my iPhone using Tapatalk
R u on base today?

Offline CaribouActual

  • ***
  • 201
  • Do it right or do it twice
Re: Clicking in front end
« Reply #20 on: March 10, 2016, 10:15:16 AM »

Engine related, maybe?


Sent from my iPhone using Tapatalk
R u on base today?

I am. I'm at work trying to google fixes and see if anyone else has had this problem (which they have).


Sent from my iPhone using Tapatalk

Offline TJ Todd

  • *
  • 2605
Re: Clicking in front end
« Reply #21 on: March 10, 2016, 10:21:40 AM »

Engine related, maybe?


Sent from my iPhone using Tapatalk
R u on base today?

I am. I'm at work trying to google fixes and see if anyone else has had this problem (which they have).


Sent from my iPhone using Tapatalk
I can look at it @ lunch if you come to building 155

Re: Clicking in front end
« Reply #22 on: March 10, 2016, 07:54:32 PM »
What Jeep are you in? Year and model.
I would rather die on my feet than live on my knees.

Offline Mark

  • *****
  • 2089
  • Mark Owens
Re: Clicking in front end
« Reply #23 on: March 10, 2016, 10:34:32 PM »
What Jeep are you in? Year and model.
I asked in a previous post, it's a LJ
Fleet of Jeeps:
XJuggy, 2 YJ's, WK (Other XJ SOLD)
Cummins 12 Valve 3500 Pig with sleeping quarters
and a trailer.

Offline CaribouActual

  • ***
  • 201
  • Do it right or do it twice
Re: Clicking in front end
« Reply #24 on: March 12, 2016, 09:23:33 PM »
Clicking was T-case chain. It was worn/loose so it would hit the housing. Replaced it and no more noise.


Sent from my iPhone using Tapatalk